--- title: "Guided Workflow | Using Door Fitter in CloudWorx for Revit" slug: "cloudworx-guided-workflow-using-door-fitter-in-cloudworx-for-revit" updated: 2026-09-14T12:26:15Z published: 2026-09-14T12:26:15Z canonical: "rcdocs.leica-geosystems.com/cloudworx-guided-workflow-using-door-fitter-in-cloudworx-for-revit" stale: true --- > ## Documentation Index > Fetch the complete documentation index at: https://rcdocs.leica-geosystems.com/llms.txt > Use this file to discover all available pages before exploring further. # Guided Workflow | Using Door Fitter in CloudWorx for Revit This guide outlines the workflow for fitting doors in CloudWorx for Revit. [Video](https://hexagondownloads.blob.core.windows.net/public/Leica/RC%20DOCS%20videos/Door%20Extraction.mp4) Video workflow for door extraction in CloudWorx for Revit ## Practice Data [Apartment.lgsx](https://hexagondownloads.blob.core.windows.net/public/Leica/Sample%20Data/Sample%20Data_Apartment.lgsx) [Panneau Plein - Ouverture ext.rfa](https://hexagondownloads.blob.core.windows.net/public/Leica/Sample%20Data/Panneau%20Plein%20-%20Ouverture%20ext.rfa) ## Setting Fence 1. After loading the dataset, use the fence tool to define the area of interest and temporarily hide unnecessary points. Click **Polygonal Fence** in the **Clipping** panel and outline the required area. ![Door fitting in Revit - Step 0.png](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/Door%20fitting%20in%20Revit%20-%20Step%200.png) ![user_cropped_screenshot.webp?tl_px=278,272&br_px=2143,1315&force_format=jpeg&q=100&width=1120.0](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot.webptl_px=278,272&br_px=2143,1315&force_format=jpeg&q=100&width=1120.0) ## Fitting Wall Before fitting the door, it is necessary to [create a wall](/v1/docs/cloudworx-guided-workflow-using-door-fitter-in-cloudworx-for-revit) where the door will be fitted. ### Creating Wall Geometry 1. In the **Fitters** panel, click **Wall**. ![Door fitting in Revit - Step 24.png](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/Door%20fitting%20in%20Revit%20-%20Step%2024.png) 2. When the **Fit Wall** dialog appears, choose **Select two points** for the pick type and click **OK**. ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(87).jpg) 3. First, select the exterior face of the wall. Next, rotate the point cloud and select the interior face of the wall. ![user_cropped_screenshot.webp?tl_px=831,425&br_px=2208,1194&force_format=jpeg&q=100&width=1120.0](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot.webptl_px=831,425&br_px=2208,1194&force_format=jpeg&q=100&width=1120.0)![user_cropped_screenshot.webp?tl_px=512,251&br_px=2232,1213&force_format=jpeg&q=100&width=1120.0](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot.webptl_px=512,251&br_px=2232,1213&force_format=jpeg&q=100&width=1120.0) 4. In the **Select wall type** dialog: 1. Select the **Create new type** check box to match the wall thickness. 2. Specify the new type name. 3. Select the **M_Exterior - Brick on Mtl Stud** wall type. 4. Click **OK.** ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(88).jpg) 5. Since the Wall Fitter tool remains active, repeat Steps 4-5 to create another wall for the area outlined in the image. The type created for the last wall can be used. ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(89).jpg) 6. In the **Rendering** panel, click **Point Visibility** to hide cloud points and display the created walls. ![Door fitting in Revit - Step 54.png](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/Door%20fitting%20in%20Revit%20-%20Step%2054.png) ### Adjusting Wall Geometry Due to the presence of openings and some noise, the wall geometry remains incomplete. This issue can be resolved using Revit functionality. 1. Click the necessary wall and then click **Trim/Extend Single Element** on the **Modify** tab. ![Door fitting in Revit - Step 56 (1).png](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/Door%20fitting%20in%20Revit%20-%20Step%2056%20(1).png) 2. Click the midpoint of the second wall to enable the Extend to boundary option. ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(90).jpg) 3. Click another wall to extend it. ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(91).jpg) 4. The walls are now joined. Enable point visibility. ![Door fitting in Revit - Step 62.png](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/Door%20fitting%20in%20Revit%20-%20Step%2062.png) 5. Click the second wall and extend it by dragging its edge to the necessary position. ![Door fitting in Revit - Step 64.png](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/Door%20fitting%20in%20Revit%20-%20Step%2064.png)![Door fitting in Revit - Step 65.png](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/Door%20fitting%20in%20Revit%20-%20Step%2065.png) ## Fitting Door ### Adjusting View 1. Use the ViewCube to adjust the view for optimal visibility of the object of interest. In this case, select the Back orientation and then pan to display the wall with the sliding glass door. ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(92).jpg) ### Adding Door Type from Autodesk Family As this project lacks the required door type, it can be selected and downloaded from the Autodesk collection. 1. Navigate to the **Insert** tab and click **Load Autodesk Family.** ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(93).jpg) 2. In the search bar of the **Load Autodesk Family** dialog, type‘*sliding door’*. ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(94).jpg) 3. Select the **Door-Double-Sliding** family and click **Load.** ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(95).jpg) 4. (Optional) Specify the required door size, if necessary. ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(96).jpg) ### Creating Door Geometry 1. Go back to the **CloudWorx** tab and click **Door** in the **Fitters** panel. ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(97).jpg) 2. When the **Fit Door** dialog appears, select the **Door-Double-Sliding** family, which is now available in the drop-down list. Click **OK**. 3. Click the host wall. ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(98).jpg) 4. The only option for door fitting is window selection. Click the upper corner and then the lower corner on the opposite side of the door frame. ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(99).jpg) 5. In **Select door family symbol** dialog: 1. Select the **Create new type** check box. 2. Optionally, adjust the dimensions and name of the newly created type. 3. Click **OK**. ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(100).jpg) 6. In Revit Project Browser, find the **L1 - Architectural** floor plan. Double-click to open it. ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(101).jpg) ### Adjusting Door Geometry Alignment 1. Enable the cloud silhouette by clicking **Silhouette** in the **Rendering** panel. 2. If the door panels are not aligned with the cloud, select the door and use blue arrows to adjust their orientation. ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(102).jpg) The door is now aligned with the point cloud. ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(103).jpg) 3. Disable silhouette mode and switch to the 3D view. ![Door fitting in Revit - Step 116 (1).png](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/Door%20fitting%20in%20Revit%20-%20Step%20116%20(1).png) ### Creating Door Geometry of Another Type Now let’s fit the door of another type. 1. Adjust the view using the ViewCube and navigate to the **Insert** tab. Click **Load Family**. ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(104).jpg) 2. In the **Load Family** dialog, select the file containing the required door family—in this case, it’s **PVC Panneau Plein.rfa**—and click **Open**. ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(105).jpg) 3. Return to the **CloudWorx** tab and enable the Door Fitter tool. ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(106).jpg) 4. As you can see, the family is loaded successfully and appears in the **Select Family** drop-down list. Click **OK** to continue. ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(107).jpg) 5. Click the host wall. ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(108).jpg) 6. Click two points on the door as described in Step 21. ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(109).jpg) 7. In the **Select door family symbol** dialog, select the **Create new type** check box and click **OK**. As a result, the door is fitted in place on the wall and cloud. ![86eaae40-6bf9-4446-bb80-6f1e97f0d987.png](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/86eaae40-6bf9-4446-bb80-6f1e97f0d987.png)![image-20251204-091744.png](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/image-20251204-091744.png) 8. To adjust the door alignment, open up the **L1 Architecture** floor plan. ![user_cropped_screenshot.webp?tl_px=573,69&br_px=1950,838&force_format=jpeg&q=100&width=1120.0](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot.webptl_px=573,69&br_px=1950,838&force_format=jpeg&q=100&width=1120.0) 9. Enable silhouette mode. If the door looks misaligned, select and drag it to make the necessary adjustments. When finished, disable silhouette mode. ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(110).jpg) 10. Switch to the 3D view to see the result. ![](https://cdn.document360.io/820e11db-8ed5-45ae-ac86-f6b77dcb2aa7/Images/Documentation/user_cropped_screenshot(111).jpg)